A AegiFlow
CRITICALCVSS 9.8EPSS 12.6%

CVE-2018-1000226

Cobbler Improper Validation of Security Tokens

Published
2022-05-13
Modified
2026-10-27
EPSS percentile
96%
Aliases
GHSA-f88q-22g8-frcg
Sources
github-advisory

Summary

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIcobbler—3.0.0

Remediation: Upgrade to 3.0.0 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.