A AegiFlow
CRITICALCVSS 9.3EPSS 1.8%

CVE-2020-10571

Potential buffer overflow in psd-tools

Published
2020-03-16
Modified
2026-09-24
EPSS percentile
78%
Aliases
GHSA-22jr-vc7j-g762
Sources
github-advisory

Summary

### Impact An issue was discovered in psd-tools before 1.9.4. The Cython implementation of RLE decoding did not check for malformed PSD input data during decoding to the PIL.Image or NumPy format, leading to a Buffer Overflow. ### Patches Users of psd-tools version v1.8.37 to v1.9.3 should upgrade to v1.9.4. ### Workarounds Without Cython present on installation, buffer overflow does not occur but IndexError will be thrown. However, already installed psd-tools with Cython extention should be upgraded. ### References https://github.com/psd-tools/psd-tools/pull/198 ### For more information If you have any questions or comments about this advisory: * Open an issue in [psd-tools](https://github.com/psd-tools/psd-tools/issues)

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIpsd-tools—1.9.4

Remediation: Upgrade to 1.9.4 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.