A AegiFlow
CRITICALCVSS 9.8EPSS 2.8%

CVE-2023-35797

Apache Airflow Hive Provider Beeline remote code execution with Principal

Published
2023-07-03
Modified
2026-10-26
EPSS percentile
86%
Aliases
GHSA-hg6c-qqcm-r79r
Sources
github-advisory

Summary

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider. This issue affects Apache Airflow Apache Hive Provider: before 6.1.1. Before version 6.1.1 it was possible to bypass the security check to RCE via principal parameter. For this to be exploited it requires access to modifying the connection details. It is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIapache-airflow-providers-apache-hive—6.1.1

Remediation: Upgrade to 6.1.1 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.