CVE-2023-46589
Apache Tomcat Improper Input Validation vulnerability
Summary
Improper Input Validation vulnerability in Apache Tomcat. Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82, and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
Affected packages
| Ecosystem | Package | Affected versions | Fixed versions |
|---|---|---|---|
| Maven | org.apache.tomcat.embed:tomcat-embed-core | — | 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96 |
| Maven | org.apache.tomcat:tomcat-catalina | — | 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96 |
| Maven | org.apache.tomcat:tomcat-coyote | — | 11.0.0-M11 |
Remediation: Upgrade to 11.0.0-M11 or later.
References
Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.
CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.
EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.