A AegiFlow
CRITICALCVSS 9.8EPSS 1.2%

CVE-2024-23730

Unsafe yaml deserialization in llama-hub

Published
2024-01-21
Modified
2026-10-27
EPSS percentile
68%
Aliases
GHSA-297x-2qf3-jrj3
Sources
github-advisory

Summary

The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIllama-hub—0.0.67

Remediation: Upgrade to 0.0.67 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.