A AegiFlow
CRITICALCVSS 9.8EPSS 1.0%

CVE-2024-3098

llama-index-core Prompt Injection vulnerability leading to Arbitrary Code Execution

Published
2024-04-10
Modified
2026-10-27
EPSS percentile
61%
Aliases
GHSA-wvpx-g427-q9wc
Sources
github-advisory

Summary

A vulnerability was identified in the `exec_utils` class of the `llama_index` package, specifically within the `safe_eval` function, allowing for prompt injection leading to arbitrary code execution. This issue arises due to insufficient validation of input, which can be exploited to bypass method restrictions and execute unauthorized code. The vulnerability is a bypass of the previously addressed CVE-2023-39662, demonstrated through a proof of concept that creates a file on the system by exploiting the flaw.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIllama-index-core—0.10.24

Remediation: Upgrade to 0.10.24 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.