A AegiFlow
CRITICALCVSS 9.3EPSS 0.9%

CVE-2024-58351

CVE-2024-58351 updated by NVD

Published
2024-11-21
Modified
2026-10-29
EPSS percentile
59%
Sources
github-advisory, nvd

Summary

Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.

Affected packages

EcosystemPackageAffected versionsFixed versions
npmflowise—2.1.4

Remediation: Upgrade to 2.1.4 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.