A AegiFlow
CRITICALCVSS 9.4EPSS 1.6%

CVE-2025-58438

internetarchive Vulnerable to Directory Traversal in File.download()

Published
2025-09-05
Modified
2026-10-27
EPSS percentile
76%
Aliases
GHSA-wx3r-v6h7-frjp
Sources
github-advisory

Summary

### Impact **What kind of vulnerability is it?** This is a **Critical** severity directory traversal (path traversal) vulnerability in the `File.download()` method of the `internetarchive` library. **Who is impacted?** All users of the `internetarchive` library versions `< 5.5.1` are impacted. The vulnerability is particularly critical for users on **Windows systems**, but all operating systems are affected. **Description of the vulnerability:** The vulnerability existed because the `file.download()` method did not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., `../../../../windows/system32/file.txt`) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. **Potential Impact:** An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. ### Patches **Has the problem been patched?** Yes, the problem has been patched. **What versions should users upgrade to?** Users must upgrade to version **5.5.1** or later. ### Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? There is no direct workaround that does not involve upgrading the library. The vulnerability is in the core logic of the file download process. The only alternative for users who absolutely cannot upgrade is to implement their own custom download function that: 1. Manually sanitizes all filenames using a robust method. 2. Validates that the resolved absolute path of the download target is within the intended directory before writing any files. However, this essentially re-implements the fix and is not recommended. Upgrading to the patched version is the only safe and supported solution. ### References - [Release Notes for v5.5.1](https://github.com/jjjake/internetarchive/releases/tag/v5.5.1) - [Commit with the fix](https://github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2) - **CVE Identifier:** CVE-2025-58438

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIinternetarchive—5.5.1

Remediation: Upgrade to 5.5.1 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.