A AegiFlow
CRITICALCVSS 9.8EPSS 1.2%

CVE-2025-67895

Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context

Published
2025-12-17
Modified
2026-10-26
EPSS percentile
67%
Aliases
GHSA-66h8-3g48-6hx8
Sources
github-advisory

Summary

Edge3 Worker RPC RCE on Airflow 2. This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if projects installed and configured it on Airflow 2. The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if projects installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do. If projects installed and configured Edge3 provider for Airflow 2, they should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has a minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2. If projects used Edge Provider in Airflow 3, you they are not affected.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIapache-airflow-providers-edge3—2.0.0

Remediation: Upgrade to 2.0.0 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.