A AegiFlow
CRITICALCVSS 9.2EPSS 0.3%

CVE-2026-102828

CVE-2026-102828 updated by NVD

Published
2026-10-05
Modified
2026-10-10
EPSS percentile
18%
Sources
github-advisory, nvd

Summary

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer. .cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

Affected packages

EcosystemPackageAffected versionsFixed versions
npmsimple-git—4.0.1

Remediation: Upgrade to 4.0.1 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.