A AegiFlow
HIGHCVSS 7.5EPSS 0.6%

CVE-2026-24734

Apache Tomcat has an Improper Input Validation vulnerability

Published
2026-02-17
Modified
2026-11-04
EPSS percentile
48%
Aliases
GHSA-mgp5-rv84-w37q
Sources
github-advisory

Summary

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

Affected packages

EcosystemPackageAffected versionsFixed versions
Mavenorg.apache.tomcat.embed:tomcat-embed-core—11.0.18, 10.1.52, 9.0.115
Mavenorg.apache.tomcat:tomcat-coyote—11.0.18, 10.1.52, 9.0.115
Mavenorg.apache.tomcat:tomcat-coyote-ffm—11.0.18, 10.1.52, 9.0.115

Remediation: Upgrade to 11.0.18 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.