A AegiFlow
MEDIUMCVSS 6.1EPSS 0.7%

CVE-2026-32773

CVE-2026-32773 updated by NVD

Published
2026-09-02
Modified
2026-10-05
EPSS percentile
51%
Sources
github-advisory, nvd

Summary

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Affected packages

EcosystemPackageAffected versionsFixed versions
Mavenorg.apache.spark:spark-core_2.12—3.5.8
Mavenorg.apache.spark:spark-core_2.13—3.5.8
PyPIpyspark—3.5.8

Remediation: Upgrade to 3.5.8 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.