A AegiFlow
HIGHCVSS 8.2EPSS 0.2%

CVE-2026-56736

CVE-2026-56736 updated by NVD

Published
2026-09-24
Modified
2026-09-26
EPSS percentile
14%
Sources
github-advisory, nvd

Summary

phpMyFAQ is an open source FAQ web application. A stored cross-site scripting (XSS) vulnerability in versions prior to 4.2.0-alpha allows any unauthenticated user (or low-privileged registered user) to inject arbitrary JavaScript that executes in an administrator's browser when they review or edit a user-submitted FAQ entry. This leads to admin account takeover via session theft. The vulnerability exists because `html_entity_decode()` converts HTML entities into executable HTML after `strip_tags()` has already passed them through, and the admin template renders the content with Twig's `|raw` filter without any output sanitization. Version 4.2.0-alpha fixes the issue.

Affected packages

EcosystemPackageAffected versionsFixed versions
Packagistphpmyfaq/phpmyfaq—4.2.0-alpha
Packagistthorsten/phpmyfaq—4.2.0-alpha

Remediation: Upgrade to 4.2.0-alpha or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.