A AegiFlow
HIGHCVSS 7.7EPSS 0.6%

CVE-2026-58168

CVE-2026-58168 updated by NVD

Published
2026-06-30
Modified
2026-10-27
EPSS percentile
47%
Sources
github-advisory, nvd

Summary

DeepTutor before version 1.4.10 contains an authorization bypass vulnerability that allows low-privilege users to invoke unrestricted MCP tools due to the allowed_mcp_tools function returning None instead of a denied result when mcp_tools is omitted from a user's grant in deeptutor/multi_user/tool_access.py. Attackers or prompt-injected content acting within a user session can enumerate and invoke any configured MCP tool, including filesystem, shell, and browser servers, gaining unauthorized access to sensitive deployment resources.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIdeeptutor—1.4.10

Remediation: Upgrade to 1.4.10 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.