A AegiFlow
CRITICALCVSS 9.3EPSS 0.5%

CVE-2026-58473

CVE-2026-58473 updated by NVD

Published
2026-07-07
Modified
2026-10-27
EPSS percentile
42%
Sources
github-advisory, nvd

Summary

Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

Affected packages

EcosystemPackageAffected versionsFixed versions
PyPIcognee—1.5.0

Remediation: Upgrade to 1.5.0 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.