A AegiFlow
CRITICALCVSS 10.0EPSS 0.9%

CVE-2026-92946

CVE-2026-92946 updated by NVD

Published
2026-10-05
Modified
2026-10-05
EPSS percentile
57%
Sources
github-advisory, nvd

Summary

vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules. Sandboxed code can require vm2's own package, instantiate an unrestricted NodeVM instance, and execute arbitrary host OS commands via child_process.

Affected packages

EcosystemPackageAffected versionsFixed versions
npmvm2—3.11.7

Remediation: Upgrade to 3.11.7 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.