A AegiFlow
CRITICALCVSS 9.3EPSS 0.2%

CVE-2026-92950

CVE-2026-92950 updated by NVD

Published
2026-10-01
Modified
2026-10-01
EPSS percentile
9%
Sources
github-advisory, nvd

Summary

vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that allows attackers to execute arbitrary code in the host Node.js process. Attackers can supply a malicious script file to the vm2 CLI that uses require(__filename) to re-execute itself in the host realm, bypassing sandbox isolation and accessing host modules like fs and child_process.

Affected packages

EcosystemPackageAffected versionsFixed versions
npmvm2—3.11.7

Remediation: Upgrade to 3.11.7 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.