A AegiFlow
CRITICALCVSS 9.9EPSS 0.5%

CVE-2026-92951

CVE-2026-92951 updated by NVD

Published
2026-10-01
Modified
2026-10-08
EPSS percentile
44%
Sources
github-advisory, nvd

Summary

vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation. Attackers can bypass the allowlist by requiring a colliding package name that contains an allowlisted package substring, causing vm2 to load and execute unauthorized host packages in the host context.

Affected packages

EcosystemPackageAffected versionsFixed versions
npmvm2—3.11.7

Remediation: Upgrade to 3.11.7 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.

Includes data from the National Vulnerability Database (NIST). NVD data is in the public domain; this page is not endorsed by NIST.

CVE® is a registered trademark of The MITRE Corporation. CVE content reproduced under the CVE Terms of Use; copyright designation © MITRE.

EPSS scores provided by the FIRST.org Exploit Prediction Scoring System.