HIGHCVSS 8.5
GHSA-6ph4-r249-58p2
Duplicate Advisory: knowns vulnerable to command injection
Summary
# Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-mc52-mwq4-vfx3. This link is maintained to preserve external references. # Original Description knowns versions before 0.30.0 fail to validate the settings.lsp.languages binary field in project configuration files, allowing attackers to execute arbitrary binaries by crafting a malicious .knowns/config.json file. When a repository with a crafted configuration is opened, the unvalidated binary path is executed twice under the user's account without any verification.
Affected packages
| Ecosystem | Package | Affected versions | Fixed versions |
|---|---|---|---|
| npm | knowns | — | 0.30.0 |
Remediation: Upgrade to 0.30.0 or later.
References
Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.