HIGHCVSS 8.7
GHSA-pvrg-q6jw-42p7
Duplicate Advisory: Traefik vulnerable to HTTP/2 request causing denial of service
Summary
### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-7v4p-328v-8v5g. This link is maintained to preserve external references. ### Original DescriptionTraefik before 2.10.5 and 3.0.0-beta4 is affected by a denial-of-service vulnerability in HTTP/2 request handling inherited from the Go standard library's HTTP/2 implementation (CVE-2023-44487 / CVE-2023-39325, the 'Rapid Reset' technique). A remote attacker can rapidly create and cancel HTTP/2 streams to exhaust server resources and cause service unavailability.
Affected packages
| Ecosystem | Package | Affected versions | Fixed versions |
|---|---|---|---|
| Go | github.com/traefik/traefik | — | 2.10.5 |
Remediation: Upgrade to 2.10.5 or later.
References
Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.