A AegiFlow
MEDIUMCVSS 6.0

GHSA-w4hm-rrxg-pxcf

Duplicate Advisory: Flowise Execute Flow function has an SSRF vulnerability

Published
2026-06-23
Modified
2026-09-23
Sources
github-advisory

Summary

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-9hrv-gvrv-6gf2. This link is maintained to preserve external references. ### Original Description Flowise before 3.1.0 contains a server-side request forgery vulnerability in the Execute Flow node that allows attackers to bypass security validation by providing intranet addresses through the base URL field. Attackers can initiate HTTP requests to internal network addresses, access cloud metadata, and enumerate internal services by exploiting the missing secureFetch verification in httpSecurity.ts.

Affected packages

EcosystemPackageAffected versionsFixed versions
npmflowise—3.1.0

Remediation: Upgrade to 3.1.0 or later.

References

Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.