GHSA-w5r9-j49j-2m55
Duplicate Advisory : Flowise has arbitrary file access due to missing chat flow id validation
Summary
### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-q67q-549q-p849. This link is maintained to preserve external references. ### Original Description Flowise before 3.0.6 (affected versions 2.2.8 and earlier) contains an arbitrary file access vulnerability due to missing validation that the chatflowId and chatId parameters are UUIDs or numbers in file handling operations. By supplying a path-traversal value (e.g., '../../../../../tmp') as the chatflow id, an unauthenticated attacker can use the /api/v1/chatflows endpoint (via addBase64FilesToStorage) to write arbitrary files, and the /api/v1/get-upload-file and /api/v1/openai-assistants-file/download endpoints (via streamStorageFile) to read arbitrary files. Arbitrary file write may lead to remote code execution.
Affected packages
| Ecosystem | Package | Affected versions | Fixed versions |
|---|---|---|---|
| npm | flowise | — | 3.0.6 |
Remediation: Upgrade to 3.0.6 or later.
References
Includes data from the GitHub Advisory Database, licensed under CC-BY 4.0.